mcmillan-ra - all messages by user

2016/12/15 10:02:53
New release update: Static lighting and OBJ import primaveranz wrote:
What is "SwarmAgent" and why does it need access through my firewall when I switch on Static lighting?
SwarmAgent is the thing that calculates the lighting.

It doesn't really need access to the internet, but it does need access to you local network as it opens up a network port for the engine to talk to. This is a standard part of UE3.
2016/12/15 10:00:20
What is the true internal resolution in Muvizu? Hi,

The engine renders at whatever size you're requesting. If you render at say 640x480 then it will use a buffer that has 307200 pixels in it. If you render at 3840x2160 then it's using a buffer that has 8294400 pixels in it. If you render with anti-aliasing on, then you're doubling the resolution in each direction - this is then "averaged" down to the original pixel size. Anything else would be wasteful and have more of a performance impact.

Because you're working with polygons, these are transformed and animated 3D space and then projected onto a 2D plane, the output resolution is totally arbitrary from the engine's point of view. Though, the higher the resolution the more it has to draw, so it will be slower.

The 3D space has full floating point resolution, so it's a good approximation of real numbers.

So, to directly answer your questions, yes it's vectorized, and no, it doesn't matter what you output at.
2016/3/11 9:37:06
x-formation software usage? Hi Johan,

Yes, Muvizu does use X-Formation as part of our licence manager. So, I don't think the file will be dangerous or malicious.

However, if the file was listed as suspect - what was is suspected of?

2016/2/29 15:10:46
Feb 2016 release feedback/bugs Hi Fazz,

I'm glad it's working, but that's a bit weird that it required the 32-bit version to be installed. The two should be installed into separate places so are actually independent of one another. Unless it's something to do with the supporting dlls (VC Runtime, DirectX etc.) but those would have been on your machine already anyway. Hmmm... weird... I'll have a look around the installer see if something's gotten confused somewhere (other than me.)
2016/2/26 15:55:34
Feb 2016 release feedback/bugs mrmuviz wrote:
It just seems weird that it worked yesterday with v1.6 but today with v1.7 the .avi doesn't work
...and a side note, the same .avi still works in version 1.6....wouldn't that make
it an issue with the new 1.7 version, and not what video codec it is?
Nevermind that it's a low rez video, I use it just for sync.
The answer to that is both yes and no.

The mechanism used to play videos is different, it's no longer using DirectShow, but is using Microsoft Media Foundation instead (if that means anything to you.) This started to be introduced in Windows Vista as a replacement for DirectShow.

We switched as it seems to be the way forward for creating and playing back video, and we had a few reports of people having issues with video playback not working. (eg:, And we'd seen the problem on a few machines internally too.

Looking through the bug report, Jamie uninstalled K-Lite and installed XVid as a standalone codec - then all worked as expected. I assume the video he had was using xvid or some other mp4 style codec.
As I said in my earlier post codec things are a nightmare and are hard to figure out, but I am fairly certain that's what it is.
2016/2/26 14:36:24
Feb 2016 release feedback/bugs Hi,

Just a few things about this release.

  • The 4K is available on windows 8 or above and only on the 64 bit version. Your mileage may vary when using it as it is really down to the power and memory of your graphics card. Older cards probably won't work.
  • The issue in MrMuviz's post with the video playback will be a codec issue. These are generally a nightmare to figure out and are pretty much out of our hands. Jamie had something similar at one point in testing but uninstalling or re-installing some codecs fixed it, I think.
  • The build now targets Windows 7. It may work in Vista, but will almost certainly not work in XP.

Fazz, were you doing anything in particular when you got that crash or was it just starting up? If you haven't already, it's probably worth uninstalling it completely - and then re-installing it.
2015/11/17 16:28:38
School with some quesitons Hi Mothj,

You can run the installer with a -s option, though I think your mileage may vary as it runs a few third party installers that do require some interaction, specifically .Net 4.5 and DirectX.

And yes, it should run on those machines. The processor's OK, but the graphics card's not amazing - as integrated graphics tend not to be, but it is DX11 compliant - the performance might not be brilliant. If you're just doing simple things on it, it will probably be okay.

The simplest thing to do is install it and see how it runs. If you've got an account, you should be able to download it to try it out.
2015/11/6 9:21:20
New "to me" Errors...Error Saving & COM Surrogate! Hi EEFilmz,

COM stands for the "Component Object Model", it's a thing in Microsoft windows that effectively allows plugin type behaviour by implementing programming interfaces. It's used in Explorer to generate thumbnails. If this process is opening files but never closing them, then it is likely this is what's causing the error. And it sounds like it is.

There's an article here, which may help.

We do install a plugin that allows us to generate thumbnails from Muvizu Sets. It's one of the install options - when it asks if you want a desktop icon etc.

You could try removing this. You could do it in a few ways: uninstall Muvizu, which will unregister it and then re-install without that option. Or if you're feeling a bit more techy than that, run a CMD shell as Administrator, and type:

RegSvr32 /u /s "C:\Program Files\Muvizu Play\Binaries64\ThumbnailExplorer7.dll"

If you've installed Muvizu somewhere other than the default path, then you'll need to adjust that accordingly. (Similarly if you're running a 32-bit build, switch 64 to 32.) You may need to reboot to kill off currently open processes and the like. If you do that and it still has a problem, then it's likely it's something else on your system causing it.

Let us know, if that was the problem...

2015/10/23 10:32:17
01/10/2105 Release Feedback Drat, Neil beat me to it... Double
2015/10/23 10:31:19
01/10/2105 Release Feedback ukBerty wrote:
I've just had to ungroup around 100 groups and move single objects manually......
ukBerty, If you right click and edit the group in the world, when it shows you the common properties one of those will be the layers. You can set the layer for the entire group there without having to ungroup, assign and regroup objects.

Sorry if it's too late and you've already done everything you need to do.
2015/10/16 11:07:36
Gimmick, gimmick, gimmick That's pretty cool.

Out of curiosity, how'd you manage it? As a guess render in 4 or 6 directions and then combine the footage afterwards?
2015/8/6 16:19:00
4/8/15 Release Bugs Hello,

OK, a new version has just been posted. The only thing different in it is that AVI output will work in DX11 mode now - so keep any other issues in here. Many apologies for that.

There will be another fix next week that will fix the "scenes being darker" problem. If you're interested, the actual problem caused by post process effects clashing with the render layers (bloom, motion blur, depth of field etc). If you render an AVI - even though the window appears darker, the actual video output should be OK.

Apologies again,
edited by Jamie on 10/08/2015
2015/8/4 17:10:24
Today's Download MrDrWho13 wrote:
A related feature request - the ability to change the layer the object's in, in its edit menu.
It's difficult to work with when you have hundreds of trees and only want to select one or two.
edited by MrDrWho13 on 04/08/2015
If you bring up its properties, it's in there. Also, if you group select your items - and bring up the edit window, you should be able to assign all of the selected ones from there too...
2015/8/4 17:07:48
Today's Download Jure wrote:
I have put a support ticket. The install path is as usual C... So I'm the only one who can't open the newest version??

I think there have been a couple of issues come in... My thought was that the install path is (by default) C:\Program files\Muvizu Play\... rather than C:\Muvizu Play\ I was just wondering if the update had gone a bit askew with that. That can be dealt with through the ticket though...
2015/8/4 16:04:54
Today's Download Jure wrote:
Hi guys, I just downloaded a new version of Muvizu but now I can't open any file. I get this message: ''fatal error! address + 0x803c80bb (filename not found) (in C:/Muvizu Play/Binaries64/Muvizu.dll)'' and similar. What should I do? Thanks!

If you haven't already - put a support ticket in. The thing that catches my attention here is the install path, have you not installed it to the root of C? Was that deliberate? Just wondering if that's related to the problem...
2015/8/4 15:58:14
Today's Download ziggy72 wrote:
SAY WHAAAAAT?!! We've only been waiting for more than 4 cameras since... forever. Muvizu HQ, this is bigger news than the render layers - please start issuing change logs!!
edited by ziggy72 on 04/08/2015
You say that now, but...

Given your sets are quite err... heavy (as an understatement) you should be able to get a bit of a speed boost from this. Generally, put all your background stuff into layers - and then hide them when working with foreground characters. Should remove lag and such like. You don't just have to use them for rendering out...

Also, from a development point of view upping the number of cameras was a simple change - the render layers - quite a bit harder to do.
2015/8/4 13:18:39
4/8/15 Release Bugs Hello,

As you may or may not have noticed we've put up another release. If you put details down about any problems or bugs you find in here, it would be appreciated. Just to keep it separate from ones in the last release.

2015/7/22 15:31:52
6/7/15 release bugs Thanks, we'll look at that for the next release (which is not too far away.)

And err... I wish we had been on holiday for 2 years.
2015/7/22 11:45:27
6/7/15 release bugs Hi folks,

We're here with some good news. We've fixed a few bugs with an interim patch release, as we work towards the next full release of Muvizu:Play. You should get prompted to update. (Or you can download afresh - and reinstall that way if you prefer.)

Here's what we've fixed (and I'm using the number system from this thread):

#1 Invisibility changes - not patched, but will be fixed in the next full release
#2 Lightning strike (character or object properties) - fixed in the patch
#3 Superheros sitting, this was fixed a couple releases ago - you may need to un-install and re-install the superheroes to make them work.
#4 Sound effects broken - fixed in the patch
#5 Favourite characters below the ground - Not patched, but will be in the next full release

There's a few other things to do with backwards compatibility there too that weren't on here. Video uploading will be available on the website again, early next week.

It's really great to see all the activity on the forums again, and we hope to see much more of it with each update in the future.

edited by mcmillan-ra on 22/07/2015
2015/3/3 8:44:28
March 2015 update bugs ziggy72 wrote:
The lighting issue I was having - this release has made the DX9 version much worse, and the DX11 version much better. The Shadow Base slider is a brilliant fix, thankyou, as it means you can tweak out the flashing and strobing as you go, which is what you need when you're in a hurry. The DX11 performance also seems to have been kicked back into life, and is more on par with DX9 again, so I I'll just switch to 11 and call it sorted Certainly all works at distance now, thanks again mcmillan-ra! Check out these trees now!!

Muvizu HQ, you've made my year already, thank-you all. Toast
I can't take the credit, it was CrazyDave who sorted it. I'll ask him to have another look at the DX9 stuff when he gets a minute though, because I think it should have been fixed for both.
pages: 1 2 3 4 5 6 7