cdunaway - all messages by user

2012/2/2 17:55:38
Microsoft Kinect Just out of curiosity, do you have any specific reasons why Muvizu should not support the Kinect? No one suggested that it should replace any existing tools, but if Muvizu supported it as an optional tool, it could open up a world of possibilities IMO.

The Windows version of the Kinect has added new features and improved others and MS has provided the SDK for free.

I don't know if it can be integrated wth Muvizu, be there seem to be many requests for different character actions. I think the Kinect would make it easier to create more.

Just my 2c
2012/2/2 5:43:54
Microsoft Kinect Now that Microsoft has released its Kinect hardware for Windows, perhaps it could be used with Muvizu or integrated in for motion capture or character movement or some other use! It could be very interesting!
2012/1/20 19:15:17
Random requests! ziggy72 wrote:
Object Mirroring! By that I mean, um, mirroring the object. So it's opposite. Y'know.

I haven't checked Muvizu yet (I'm a n00b) but in some applications you can create a mirror effect by scaling in the negative direction and for some you scale to -1 which results in a mirror effect. Is that a possibility here? Just allow scaling in the negative direction?
2012/1/20 18:58:22
Camera Options and Filters One camera type request that I think would be nice would be to be able to specify a camera "target". So in the camera setup, if I specify the target of the camera as my character, for example, then no matter how I move the camera, it always points at my target.
2012/1/18 1:18:01
Help exporting from Blender 2.61 Jamie wrote:
Glad that's fixed it for you Chris. This is the plugin I've been using -

Yes, that is the script I am using also. I altered the script to remove extra spaces on or about line 278. There are other sections in the script which output extra spaces. I don't know if they cause any adverse effects in Muvizu, however.

Thanks again!
2012/1/17 0:04:02
Help exporting from Blender 2.61 Thanks Jamie!

That did the trick. Just removing the extra spaces at the end of the line caused it to work.


For anyone that is interested, the python script was the culprit.

In an effort to keep the source code neat, the author added spaces to each line to indent the code, but those spaces were being output to the .ase file. The extra spaces were causing Muvizu to fail.

I can adjust the python script in Blender to take care of this, but I still feel this is a bug in need of repair.


edited by cdunaway on 17/01/2012
edited by cdunaway on 17/01/2012
edited by cdunaway on 17/01/2012
2012/1/15 17:52:46
Help exporting from Blender 2.61 The plot thickens!! From your test file, I copied the BITMAP line and merely overwrote the existing line in my file, and now my file imports correctly, even though that folder does not exist. It also works if I substitute my name instead of yours in the path.

What is strange, after I get it to import, if I change it back to what I had originally by manually typing it in, it works, but if I use the Undo feature (Ctrl-Z) in my text editor to revert it back to what I originally had, it then fails to import again! I looked at the file under a hex editor and I cannot see any strange characters and the file doesn't seem to be encoded in any special way.

I feel that this may be a bug in Muvizu.
2012/1/14 21:45:40
Help exporting from Blender 2.61 Thanks, I tried your file and it imports correctly as well. I can't see any significant difference between the two. I did notice in my file, under the MESH_TVERTLIST section, that there are 36 entries where yours had only 24. Some of them appear to be duplicates. I'm not sure what that section is used for, however.
2012/1/14 18:20:20
Help exporting from Blender 2.61 Dylly wrote:
Hi Chris,

First of all let me say that I tried blender and it confused the hell out of me, so I moved on to 3ds Max, a free lite version can be had at, now back to your problem...

Blender has improved dramatically since version 2.49 with a totally revamped UI, but I guess its workflow is still different that 3DS Max!

I went through similar steps again and still have the same issue. I moved my files to a subfolder on the D: drive (D:\MuvizuTest) and got the same error:

"There was an error importing the object" "File not found." D:\MuvizuTest\textures\TestCube.png

Dylly wrote:

I think in the case of your model it may be looking for a folder named 'textures' as this could be where Blender stuffs the UVW when it unwraps it and the new map has not been added to the model, so Muvizu is still looking for the original UVW unwrap file and not your texture map.

This is what puzzles me, however. How would Muvizu know to look for a folder called "textures"? Nowhere in the .ase file is that folder indicated. Does Muvizu somehow know to look into the .blend file? I wouldn't think so.

I have placed a .zip file which contains the Blender .blend file (v2.61), the .ase file produced by the export script, and the .png file that I created for the texture at the following location:!240&parid=1A1A8325D45B2AC0!201

If there is anything else you would like to see, please let me know.

Thanks for the help!

2012/1/14 0:54:12
Help exporting from Blender 2.61 Firstly, I'm new to Muvizu but have watched all the tutorials. Secondly, I'm inexperienced in Blender (which may be the root of my problem!)

I am attempting to learn how to import a model into Muvizu created in Blender. To keep it simple, I started with a plain cube. I added a material and a texture, I UV unwrapped the cube and then used the ASE exporter found at It seemed to create the ASE file and I placed it along with a .png for the texture in the same folder. They were named ob_testbox.ase and testbox.png. When I attempted to import the model into Muvizu, I got an error:

"There was an error importing the object" "File not found." D:\textures\testbox.png

Both the .ase file and the .png file for the texture are located in the root folder of D:. Why is it looking in the textures folder (which doesn't even exist)? Inside the .ase file, there is a BITMAP setting with what seems to be the correct filename for the .png file, so I don't know where or why it is looking for a folder called "textures".

I can post the contents of the .ase file if anyone is interested. I have tried tweaking the file by changing the path of the image. I have tried creating the "textures" folder and placing the image there but I still get the same error.

I'm thinking that I have missed some important step in Blender when creating the model or the ASE export script might be producing something that is incompatible with Muvizu. I have compared the .ASE scripts from a model downloaded from the Gallery (which imports fine) against the one produced by Blender and they seem to be the same. The Blender script puts some additional things in there. I tried making the script look as close as possible to one that imports correctly, and it still doesn't work.

Can someone post a simple model of a cube with a plain image texture (not an id texture, I'll tackle them next) or some step by step instructions for creating a model in Blender? Any hints or tips will be appreciated.

I am using the newest version of Muvizu (MZASS-v0.19b - build 2012.01.10.01R (64-bit)) and the latest version of Blender (2.61.0 r42615)

Sorry for the long post, but this has been a frustrating experience and I just need some help to make it "click"!


pages: 1