Messages in this topic - RSS

Home ? Tech Help ? anti-aliasing

pages: 1 2 | the topic is closed
12/09/2012 15:28:30

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Hi,

when i tick the anti-aliasing button it makes no differance. It used to work in older versions for me.

Is it working for anyone else ?
permalink
12/09/2012 17:15:13

JamieMuvizu staff
Jamie
(Account inactive)
Posts: 609
Yeah, it's working for me in the release from yesterday. I put a Beefy character in front of a camera and went to make video, opened options and ticked and unticked the Anti-aliasing option and there was a clear difference.

Maybe a screen shot of it on and off could help?
What graphics card are you using and what version of Direct X?

--
Direct, don't animate!
permalink
12/09/2012 19:30:34

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Im using the 2012.07.16.01R_x64 build.

But I've also tryed the latest release and I still can't get anti alias to work on that too.

Heres a pic

Im using DX 11 and I have a quadro 2700m with up to date nvidia drivers. Anti alias use to work great on this computer back when i made the dark ninja stuff. I tryed back dating Nvidia drivers but still have no luck.
permalink
12/09/2012 20:10:31

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
Think you may have a codec problem JB. I tried the same thing, but all was fine (using my normal iYUV codec). Switched to ffdshow, turned off the AA, rendered a test shot, and it came out fine on playback. Turned on the AA, rendered the same shot, and it came out like this on playback :



Tried again, no changes, and it came out fine. Why it should be doing this I don't know, but I find that Muvizu doesn't get on all that well with other codecs in 64 bit mode. Good luck with this one!
permalink
12/09/2012 22:22:07

DreekoMuvizu mogulExperimental user
Dreeko
Posts: 1258
I just did a little test render and all is fine here. Codec in use is motion jpeg in ffdshow
permalink
12/09/2012 22:47:52

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
It must be my computer then. If I remember correct as soon as u tick the anti alias box u should see the change in the make video window, so it not a codec related its more a direct x thing.

I'll have to try find out what the older drivers was that i used for this silly graphics card LOL.

Thanks for all trying.
permalink
13/09/2012 00:21:09

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
OK I know this isn't a problem for everyone but I'll list what I've found out about my issue.

Here goes Jamie its a long one LOL

Firstly it doesn't seem to be a problem with my graphic drivers.
I tryed various older versions and the problem is still there.
On the latest nvidia drivers I can force anti alias on the muvizu application without a problem.
Everthing is anti aliased and very smooth on the muvizu application apart from what is inside the make video window.
objects inside that window remains jagged ( WEIRD! )

Next thing I tryed is to rollback muvizu.
I found that the MuvizuSetupDXDotNet_2011.09.20.01R_x64.exe release
Works fine and I get anti alias when I tick the box just fine. Alls good and smooth on this release for me.

Any version after 2011.09.20 does not allow that application to enable anti alias on my system for some reason.

I've tryed the following versions.
MuvizuSetupDXDotNet_2012.05.04.01R_x64.exe No anti aliasing
MuvizuSetupDXDotNet_2012.06.14.01_x64.exe No anti aliasing
MuvizuSetupDXDotNetFull_2012.07.16.01R_x64.exe No anti aliasing
MuvizuSetupDXDotNetFull_2012.09.11.01R_x64.exe No anti aliasing

MuvizuSetupDXDotNet_2011.09.20.01R_x64.exe Works and HAS anti aliasing

Anyways I hope this is useful jamie.
.
edited by jonbez on 13/09/2012
permalink
25/09/2012 20:02:47

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Today I tryed installing the latest version of muvizu on another PC and still I get no anti aliasing with the box ticked.
The only way i can get the anti aliasing tickbox to work is to install an older version of muvizu.
Everything works great with this version MuvizuSetupDXDotNet_2011.09.20.01R_x64.exe

This is the specs of the machine I tryed today

Windows 7 64bit
GeForce GTS 250 with the latest nvidia drivers 306.23
DX 11

Any help would be appreciated
permalink
26/09/2012 10:44:00

JamieMuvizu staff
Jamie
(Account inactive)
Posts: 609
Very frustrating John!

Have you tried using DX9 to see if that works? I can understand why your wanting to use DX11 but if it works with DX9 then it would give us a starting point to understand what's going on. I don't think this is a codec issue, you should be able to see the effect of AA within the 3D environment as well as on the make video window.

--
Direct, don't animate!
permalink
27/09/2012 15:12:53

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Hi Jamie
When I type dxdiag in windows 7 it says DirectX version: DirectX 11

But in muvizu > help > system Info, It says directx v10.0 at the top with my system details and right at the bottom it says using directX 9 renderer.

So dx 9 10 and 11 are mentioned in different places. How can I just force my system to use just directX 9

Any ideas

Also I noticed the 2011 builds i get anti alias. Did you guys update to a newer version of the engine in 2012 ?
permalink
28/09/2012 12:41:11

JamieMuvizu staff
Jamie
(Account inactive)
Posts: 609
Hi John,

The latest version of DX has components of 9, 10 and 11 in it, So technically you can have all 3 but the one Muvizu is using is the one you pick from the drop down menu in Muvizu's options (file > options).

The engine was updated at the start of 2012 so, yes, it could be a contributing factor.

So far we've tried 4 computers (or is it 5?) you've tried it on 1 or 2? and I've tried it on 3 computers in the office. The results are that 2 do display AA as expected and one does not.

So we're still a bit stumped, at least we are able to reproduce it on one computer now!

--
Direct, don't animate!
permalink
28/09/2012 14:39:10

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Thanks for looking into it. Im glad you guys can reproduce it, Hopefully you can find the problem.
BTW I dont see any options for directx in file > options.

Just so u know I can force AA on muvizu through the nvidia control panel. It applies AA to everything as expected, but the only thing that shows no AA is what is inside the make video window. Is something hard coded to that window ? Its weird that I cant force that window too. Also Tweeking the MuvizuEngine.ini files has no effect either.

Cheers for the help jamie
edited by jonbez on 28/09/2012
permalink
28/09/2012 19:47:44

urbanlamb
urbanlamb
(Account inactive)
Posts: 1796
can i add to this a bit? lol sorry

Anyhow I started doing video last night or two now rendering scenes. I switched from dx9 to dx 11 and the antialias problem seemed (seemed) to happen in dx11 when I switched so I am busy switching back and forth I dont know if this is due to pc or something else so here is my system info from my dxdiag file err what I think is relevant .

I guess I should add this is only with this most recent build when you also released the assets package to go with the heroes/villains characters last month. So its new (for me anyhow)

(notices as i cut and paste this i am still using service pack 1 for windows 7 .. thought i upgraded it)


System Information
------------------
Time of this report: 9/28/2012, 14:43:01
Machine name: REVEL-PC
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: EX58-UD5
BIOS: Award Modular BIOS v6.00PG
Processor: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz (8 CPUs), ~2.8GHz
Memory: 12288MB RAM
Available OS Memory: 12286MB RAM
Page File: 2814MB used, 21754MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode

---------------
Display Devices
---------------
Card name: NVIDIA GeForce GTX 560 Ti
Manufacturer: NVIDIA
Chip type: GeForce GTX 560 Ti
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_1200&SUBSYS_15613842&REV_A1
Display Memory: 4050 MB
Dedicated Memory: 978 MB
Shared Memory: 3072 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: 227ELPH
Monitor Id: PHLC07A
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HD15
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 8.17.0013.0142 (English)
Driver Version: 8.17.13.142
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 5/15/2012 06:48:00, 18044224 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71E3E-5140-11CF-7C5B-6C351FC2C535}
Vendor ID: 0x10DE
Device ID: 0x1200
SubSys ID: 0x15613842
Revision ID: 0x00A1
edited by urbanlamb on 28/09/2012
permalink
01/10/2012 11:32:46

JamieMuvizu staff
Jamie
(Account inactive)
Posts: 609
Just putting some info together here about where this problems happens, thanks for the contributation UrbanLamb. So far it seems to only affect NVIDIA cards. I've tried several ATI / AMD cards and each time they have given the expected result.

At Muvizu HQ we have reproduced the problem on an NVIDIA 310

John, you've used a GTS 250 and a Quadro FX 2700M? This one? http://www.nvidia.com/object/product_quadro_fx_2700_m_us.html

UrbanLamb you have this problem on a GTX 560 Ti ?

So the list of cards NOT working is -

NVIDIA Geforce:

310
GTS 250
Quadro FX 2700M
GTX 560 Ti

Cards that ARE working -

NVIDIA Geforce:

370M
GTX 460

I'd be interested to hear from anyone using Muvizu with one of these graphics cards who has AA working as expected or if you have a different model of graphics card and this problem let us know as well. Of course if you have the AA problem with one of these cards then speak up as well, it's useful to know how wide spread this problem is.

--
Direct, don't animate!
permalink
01/10/2012 11:41:12

JamieMuvizu staff
Jamie
(Account inactive)
Posts: 609
Couple other things worth noting:

Drivers don't seem to change this, the one computer this happens on in the office had drivers from about 1 year ago and was then updated to the most recent version.

If you go back to Direct X 9, UrbanLamb, do you get the expect AA result in the Make Video window?

John - can you double check the direct x settings under file > options? The only time they wouldn't be shown is if you only had DX 9 installed, in which case there is no other choice available so it hides the option. It should go Video header (resolution, codec, configure codec button, AA check box) then Rendering (Direct X version drop down list).



--
Direct, don't animate!
permalink
01/10/2012 13:53:20

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
My directX was installed with the windows 7 installer. I've added all info into one picture. as u will see in one place it says i have dx 11 but muvizu says 10 but is rendering with 9. so i have access to all three like u would expect in DX11
permalink
01/10/2012 14:00:58

jonbezMuvizu mogulExperimental user
jonbez
Posts: 201
Just for the record. I have dx11 installed but I think my graphics card is only capable of run DX10.
permalink
01/10/2012 15:44:45

urbanlamb
urbanlamb
(Account inactive)
Posts: 1796
hi unfortunately once i decided to mess with options the problem came up and has not gone away here is a photo of something I was working on last night.




and yes the card i am using for this stuff is the gtx 560ti nvidia and it looks like this in dx9 and dx11.
edited by urbanlamb on 01/10/2012
permalink
24/10/2012 16:36:20

CrazyDaveMuvizu staff
CrazyDave
Posts: 118
Hi guys.

Firstly, sorry for the slow response on this issue, I've been really busy with other tasks...

I'm working on a proper fix in time for the next release, but in the mean time it's likely that you can get your anti-aliasing to work by starting Muvizu with the command line parameter -forceMSAA.

The easiest way to do this is to edit the properties of the shortcut with which you launch Muvizu (or make a new one) and add "-forceMSAA" (no quotes) at the end of the "Target" text field.

Cheers, Dave.
permalink
24/10/2012 17:44:59

urbanlamb
urbanlamb
(Account inactive)
Posts: 1796
CrazyDave wrote:
Hi guys.

Firstly, sorry for the slow response on this issue, I've been really busy with other tasks...

I'm working on a proper fix in time for the next release, but in the mean time it's likely that you can get your anti-aliasing to work by starting Muvizu with the command line parameter -forceMSAA.

The easiest way to do this is to edit the properties of the shortcut with which you launch Muvizu (or make a new one) and add "-forceMSAA" (no quotes) at the end of the "Target" text field.

Cheers, Dave.



oh wow thanks.

my stuff is not that bad there are ways to hide it a bit but in some shots it was so painfully hitting me in the face obvious lol, but I dont know if the average viewer of the videos would notice it
edited by urbanlamb on 24/10/2012
permalink
pages: 1 2 | the topic is closed

Home ? Tech Help ? anti-aliasing